Raid – Hot Swap Platte hat sich abgehängt

Um Missverständnisse zu vermeiden möchte ich zuerst klarstellen dass ich kein Hardware Profi bin. Und so soll dieser Beitrag vor allem auch dazu Dienen, dass ich mich in einigen Monaten wieder daran erinnere was ich selbst getan habe um mein Problem, was ich nun beschreibe zu beheben.

Adaptec-2100S Einer meiner Server (ich nenne ihn immer „den Alten“ muss schon lange ausgetauscht werden, aber er läuft und läuft und …), ein Fujitsu Siemens ist mit einem Adaptec 2100 Ultra Wide Raid Controller ausgestattet. In diesem Rechner werden 3 Hot Swap Festplatten im Raid-5 betrieben.

Nun ist, aus welchen Gründen auch immer bei einer der Festplatten die Rote Betriebsleuchte, oder soll ich besser sagen Störungsleuchte angegangen. Ich weiß aus der Vergangenheit (hatte das vor ca. einem Jahr schon mal) dass dies geschehen war, weil die Festplatte nicht mehr Synchron mit den anderen Festplatten war.

Nun habe ich gedacht, dass ich beim letzten mal dem Raid Controller per Software gesagt habe, dass er die abgehängte Festplatte wieder synchronisieren soll. Aber meine Suche nach der Software mit der ich dem Controller dieses gesagt haben wollte, konnte ich einfach nicht finden, vermutlich gibt es eine solche Software, aber es geht eben auch ohne.

Nachdem ich aber die Software einfach nicht finden konnte, habe ich aber doch noch Glück gehabt und habe mich kurz darauf daran erinnert was ich das letzte mal bei einem solchen Problem gemacht hatte. Übrigens ist das genau der Grund warum ich es dieses mal aufschreibe, ich möchte das nächste mal einfach meine eigenen Notizen lesen und wissen was ich zu machen habe.

Hier nun kurz und amateurhaft die Beschreibung dessen was ich gemacht um die abgehängte Festplatte im Raid wieder zu synchronisieren.

Ich habe einfach die Festplatte aus dem Einschub herausgezogen (während des Betriebs, sind ja Hot Swap Festplatten), und dann nach einer kurzen Zeit (1 Minute) die Festplatte wieder in den Einschub gesteckt. Nach einigen Sekunden hat der Controller erkannt das ich eine Festplatte in den Einschub geschoben habe und sofort hat der Controller angefangen die Festplatten zu synchronisieren (Rote und Grüne Lampen haben wild geblinkt).

Nach ca. 24 Stunden (können auch einige Stunden weniger gewesen sein, habe nicht die ganze Nacht vor dem Rechner verbracht) hat das wilde Blinken der Roten und Grünen Lampe aufgehört, die Rote Lampe ist danach ausgegangen und die Grüne Lampe blinkt nun wieder rhythmisch mit den Grünen Lampen der beiden anderen Festplatten.

Wie ihr, anhand meiner recht amateurhaften Beschreibung von blinkenden Grünen und Roten Lampen der Festplatten, feststelle könnt bin ich nicht der Hardware Profi, aber das habe ich einleitend ja bereits erwähnt.

Aber wer weiß, eventuell geht es ja jemand der auch kein Hardware Profi ist mal genau so und stolpert über diesen Beitrag und die Informationen hier können Ihm/Ihr helfen das System wieder Normal Betreiben zu können.

Anregungen und Vorschläge wie man es besser (anders) hätte machen können dürfen natürlich gerne als Kommentar hinterlassen werden.

3 Gedanken zu „Raid – Hot Swap Platte hat sich abgehängt“

  1. puh, da hat aber einer mut.

    Wenn die Platten nicht mehr synchron sind, hatte das einen Grund.
    Gerade bei einem Server solltest Du dann schleunigst zusehen, das du eine neu Platte
    bekommst, denn was ist, wenn beim nächsten mal 2 Platten nicht mehr synchron sind?
    Du verlierst alles.

    Also nicht blauäugig die Platte neu synchen, sondern austauschen.

  2. Ich werde das im Auge behalten!
    Da es sich bei dem Server, wie ich geschrieben habe um "den Alten" handelt, und ich:
    a) Keine relevanten Daten und Dienste mehr auf diesem Server habe
    b) Trotzdem regelmäßige (Tägliche) Datensicherung erstelle.
    Würde der Ausfall der Platten nicht wirklich schaden anrichten.

    Gibt es denn für das abhängen der Platte wirklich nur den Grund das diese gleich Defekt ist. Ich hatte dieses Problem vor ca. 1 Jahr schon mal mit diesem Server, damals war es eine andere Platte, und die läuft seit dem wieder ohne Probleme.

    Trotzdem Danke für den Hinweis, und wenn es ein relevanter Server wäre, hätte ich wohl auch nicht den Mut dazu gehabt.

  3. Auch wenn der Post schon alt ist; ich bin gerade noch einmal darüber gestolpert und möchte dem Kollegen (FZelle) der hier seinen Kommentar hinterlassen hatte auf jeden Fall recht geben, und jeden davor warnen einfach die Platte neu zu synchronisieren.

    Die Platte ist damals nach ca. 2 Wochen wieder ausgefallen. Ich habe dann die Platte erneuert bevor, nur 2 Tage später
    tatsächlich eine weitere Platte ausgefallen war.
    Also, wenn eine Platte im Raid,wie hier beschrieben ausfällt, dann raus damit und keine Versuche mit Neu Sync.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.